Problem with simulate 3D with stl.file

Hello guys!
I try to simulate an 3D flow around a cylinder by an given domain from an stl-file. Itself, an simple flow problem.
I tempted to use the given aneurysm-code and modified it for my purposes.
The domain and geometry is given by an rectangular domain with an cylinder cross inside of it. The inlet and opposite outlet are open, as requested.
In the code i replaced:

computeInnerRadius ();


And changed all attached variables. Please correct me, if it is the wrong setting for an rectangular inlet.

For the output settings, i changed the probe-point-coordinates depend on the physical measures of the “new” domain.
In the xml-file, i changed all descriptive data for my object.
The settings, which are pcout in the terminal are ok, in my opinion:


But i got two problems, and cannot figure out the reason:
At first, i got 1.334 million allocated cells and a fraction of 100percent allocated cells.(i turned off sparse domain, cause of the rectangular domain)
The problem; the number of fluid cells which are denoted in the terminal count only 183195. That cannot be, because the cylinder is small, relativ to the whole domain. I expected a number of fluid cells near to the number of allocated cells. Whats wrong? The provided inlet-direction is correct.

And the second problem:
While processing ive got an average energy of zero for each output timestep. (i turned off poiseuilleInlet, to get an plug profile) 
And following messages apear:
Offending vertex: 1.5000, 136.398, 30.98
Offending vertex: ......
Warning: in vtkForVertices, the number of particles doesn't match the number of vertices. 
There might be black spots in the produced VTK file.

All output files are unreadable with ParaView or senseless.
Is it an issue of the given stl-file? are there specific conditions for the triangular surface of the slt-mesh?
The metric scale of the geometry-file should be correct.

I would be grateful for any help!

Yes I was trying to do something similar. I even tried to read through the relevant parts of the paraview manual. But when I load the vtk files it just hangs. Did you fix it?

Unfortunately, i cant fix it.
I guess, it was an issue of the input STL-file. Even if i changed the triangular-grid of the geometrie file, the results of the simulation got changed. And i dont know what conditions have to be affected to the stl-file.
In the end, i build the geometry manually in the code. But for more complex geometrys its going to be an problem.

By using the aneurism code, is your cylinder represented as JUST the cylinder , or is it the domain with a cylindrical hole??? the aneurism bounds are defined by the stl file, and the flow is internal. I can have a look at your code. That may help you and me, since we’re working on similar things.


I am new to Palabos and I am struggling. I am also using the aneurysm simulation as a base. I have edited the param.xml file for my simulation. I have also edited the output positions and planes to suit my domain. However, I am not sure what else to modify in the code to taylor it to my problem. So far it compiles fine. It also begins to run but I get the error below.

Reynolds number, based on provided inlet diameter: 119522

Running new simulation at level 0

[muaaz-Dell-System-XPS-L502X:06928] *** Process received signal ***
[muaaz-Dell-System-XPS-L502X:06928] Signal: Segmentation fault (11)
[muaaz-Dell-System-XPS-L502X:06928] Signal code: Address not mapped (1)
[muaaz-Dell-System-XPS-L502X:06928] Failing at address: 0x10
[muaaz-Dell-System-XPS-L502X:06928] [ 0] /lib/x86_64-linux-gnu/ [0x7f7396d99cb0]
[muaaz-Dell-System-XPS-L502X:06928] [ 1] ./aneurysm(_ZN3plb17computeBaryCenterIdEENS_5ArrayIT_Lm3EEERKNS_21TriangularSurfaceMeshIS2_EERKNS_3LidE+0x17) [0x4bea77]
[muaaz-Dell-System-XPS-L502X:06928] [ 2] ./aneurysm(_Z11setOpeningsRSt6vectorIPN3plb17BoundaryProfile3DIdNS0_5ArrayIdLm3EEEEESaIS5_EERNS0_18TriangleBoundary3DIdEEddd+0x49d) [0x48f3fd]
[muaaz-Dell-System-XPS-L502X:06928] [ 3] ./aneurysm(_Z3runlPN3plb19MultiBlockLattice3DIdNS_11descriptors15D3Q19DescriptorEEE+0x665) [0x495c45]
[muaaz-Dell-System-XPS-L502X:06928] [ 4] ./aneurysm(main+0x297) [0x487997]
[muaaz-Dell-System-XPS-L502X:06928] [ 5] /lib/x86_64-linux-gnu/ [0x7f73969ec76d]
[muaaz-Dell-System-XPS-L502X:06928] [ 6] ./aneurysm() [0x489901]
[muaaz-Dell-System-XPS-L502X:06928] *** End of error message ***
Segmentation fault (core dumped)

I have isolated it to the following part of the code, but I do not know what to change to make it work for my problem. Any Ideas as to where I am going wrong?

void setOpenings (
std::vector<BoundaryProfile3D<T,Velocity>*>& inletOutlets,
TriangleBoundary3D& boundary, T uLB, T dx, T dt )
for (pluint i=0; i<openings.size(); ++i) {
pcout << i << std::endl;
Opening& opening = openings[i]; = computeBaryCenter (
boundary.getInletOutlet(openingSortDirection)[i] );
opening.innerRadius = computeInnerRadius (
boundary.getInletOutlet(openingSortDirection)[i] );

    if (opening.inlet) {
        if (poiseuilleInlet) {
            inletOutlets.push_back (
                    new PoiseuilleProfile3D<T>(uLB) );
        else {
            inletOutlets.push_back (
                    new VelocityPlugProfile3D<T>(uLB) );
    else {
        inletOutlets.push_back (
                new DensityNeumannBoundaryProfile3D<T> );


Thanks in advance.



I have three questions:
Is the problem solved?
What is the name of softwares with .stl output?
.stl file only introduce boundaries coordination not the grid. is it true?