Palabos 80days cuda version issues

Thanks for great job and thanks for sharing it with community.
I have tried to compile CUDA version example (rayleighTaylor3D).
First of all that is strange that git clone does not clone 80days directory while it presents in source zip file (i’m not expert in git, mb it is hidden somehow in a way that i don’t understand).
Second, when I try to compile cuda version (starting from downloaded dir):
cmake …
It fails on 99% with:
n file included from /home/oryabkov/install_local/palabos_cuda2/palabos-master/examples/80days/rayleighTaylor3D/…/…/…/src/atomicBlock/headers3D.hh:44,
from /home/oryabkov/install_local/palabos_cuda2/palabos-master/examples/80days/rayleighTaylor3D/…/…/…/src/palabos3D.hh:42,
from /home/oryabkov/install_local/palabos_cuda2/palabos-master/examples/80days/rayleighTaylor3D/rayleighTaylor3D.cpp:49:
/home/oryabkov/install_local/palabos_cuda2/palabos-master/examples/80days/rayleighTaylor3D/…/…/…/src/atomicBlock/atomicAcceleratedLattice3D.hh:53:10: fatal error: execution: No such file or directory
#include <execution>

uname -a
Linux Cluster 5.4.0-72-generic #80-Ubuntu SMP Mon Apr 12 17:35:00 UTC 2021 x86_64 x86_64 x86_64 GNU/Linux
gcc --version
gcc (Ubuntu 8.4.0-3ubuntu2) 8.4.0
nvcc --version
nvcc: NVIDIA ® Cuda compiler driver
Copyright © 2005-2019 NVIDIA Corporation
Built on Wed_Oct_23_19:24:38_PDT_2019
Cuda compilation tools, release 10.2, V10.2.89

I have rather old cuda but I cannot install newer version because of old cards limitation

Thanks in advance.

A little update.
Obviously, problem with <execution> was caused by old nvcc (no --std=c++17 is supported in cuda 10). I compiled these examples on the machine with 11.3 cuda and it could make it.
However, when I run the code it works in multi threaded regime and doesnot use nvidia card.
I tries add #define ACCELERATOR PAR_ALG in the beginig of the code as was mentioned in readme but it didn’t work. I tried ENABLE_CUDA, but it was ignored. I tried to build top level code (top level cmakelists instead of cmakelists inside examples) with ENABLE_CUDA but it failed.
So obviously, I’m doing something wrong. Any tips, please?

1 Like

Were you able to figure it out?