Issue with "fseeko64"

Hi, I’d very much like to use Palabos to start learning actually applying LBM to real problems, but I’m truly feeling how new I am to working with this type of programming. At the moment, when I try to compile one of the examples, I get an error message asking if “fseeko64” should really be “fseeko”. I tried fiddling around a bit, changing the indicated lines, but of course, that only causes a cascade of new name errors. Is there perhaps someone here who might offer some insight on this?

Dear Amadeus,

if your compilation problem is on a Mac, then maybe it would be helpful to you to check the compilation guideline for Mac OS X at:


Indeed it would, which is also one of the prime reasons that I have done so. Please forgive me, I am quite new to all of this, and there may be assumptions of foreknowledge that I do not possess yet. I try following every line of the instruction, up to the point where I’ve navigated (by terminal) to the showCase cylinder2D. I know I had changed compileFlags to the proper line earlier (it is correct that it should ONLY be equal to PLB_MAC_OS_X, right?) when I got the fseeko64 issue… however, now it just leaves me with

clang: error: no such file or directory: ‘PLB_MAC_OS_X’.

Xcode is indeed installed, and command lines tools downloaded. Please, I’ve been running around in circles for a while now, is there anything else fundamental that I must be missing to give this error?

You should have:

compileFlags = -Wall -Wnon-virtual-dtor -DPLB_MAC_OS_X

Hope this helps,

Hey, I just wanted to come back here and say that everything seems to have worked out in the end; I misread the section about the flag and copied the wrong line. Maybe I would have worded that part a little different, but the error was still mine and now I’m up and running with the tutorials. Thanks for taking the time to answer my questions!