Compiling Palabos 2.0 using a 64bit Compiler on Windows


Has anyone compiled Palabos 2.0 using a 64bit compiler on windows 10? Which compiler are you using? I tried using a 64bit version of Mingw but it is giving me this error:

…\src\gridRefinement\couplingInterfaceGenerator3D.h|145|error: invalid initialization of reference of type ‘plb::MultiContainerBlock3D&’ from expression of type ‘plb::MultiContainerBlock3D*’|


this is indeed a bug/typo in the code. To compile successfully, please change line 145 of the file:



return *dataProcessors;


1 Like

This saved my life!!!

Just for information, this wasn’t just an error on Windows systems, because I was getting the same error messages on Linux (which is kinda obvious, since the src files are the very same).

I was almost pulling my hairs out, trying to figure what the heck was happening. I’m working in a 2D code with grid refinement, and this error about a 3D library made no sense.

I modified the src and it compiled flawlessly. Thumbs up :wink: