error message


I tried to run a simulation on a CT image of size 252 X 252 X 252. I was able to run the make files successfully but when I tried to run the code, I got the following error message
. Can anybody explain to me the meaning of the error message?

cavity3d(42400) malloc: *** mmap(size=2530123776) failed (error code=12)
*** error: can’t allocate region
*** set a breakpoint in malloc_error_break to debug
terminate called after throwing an instance of ‘std::bad_alloc’
what(): St9bad_alloc
Abort trap

Hey, I am jealous: your computer is much more explicit than mine. It actually tells you right away, in the first line of the error message, that it failed while trying to allocate 2.5 GB of memory. The computer doesn’t have that much memory, right?

Memory usage can be predicted roughly by multiplying the number of cells (250^3) by the number of particle populations (19 for D3Q19) and the number of bytes for floating point value (8 for double precision).

If there’s a computing cluster at your institute, you can run the program in parallel to circumvent the memory issue.

Thanks Jonas

You really made my day with the explanation. I did have this feeling that it had to do with memory. I did the calculation and it turned out to be the value due to a size of 252^3. My laptop has a RAM of 2GB but I know the free RAM is even less. Thus it means that the memory space is small.
We do have a computer cluster in our Institute. My application for allocation is yet to be approved. Once it is, I would run the simulation on it and hope it turns out well.



I decided to do a test run of a system initially at rest. I used the poiseuille flow with velocity defined at zero everywhere initially. I used an inlet pressure of 1.01 and an outlet pressure of 1 (actually density) and linear interpolation for in between values. In the LBunits, I put a Reynolds number of 0 while my Umax = 0.02 As such I defined my my omega manually to be 1.05.
During the simulation, I found out that my Umax had negative values up to the power of -15 and my and the flow field images were distorted, obviously not the Poiseuille profile I was expecting.
What do you think would have caused this?