Compile problemas

Dear community of Palabos,

I am trying to run your software for academic studies and when I try to execute the “make” command in order to comile the tutorial_1 an error comes out. It says
“sh: mpicxx: command not found”
“scons: *** [tutorial_1_1.o] Error 127”

“make: *** [compile] Error 2]”
I am trying it with MAC OS X 10.11.6 and I have downloaded xcode as it is said. I have also try to introduce “-DPLB_MAC_OS_X” but nothing changes.
I would be pleased if anyone of the palabos community may help me.
Thank you very much in advance and congratulations for the software.


Guillermo Izquierdo Bouldstridge

Dear Guillermo Izquierdo Bouldstridge,

I have no experience with running palabos under Mac OS, but at a first glance, this looks like a problem with your mpi installation. You should check whehter an MPI library (e.g. openmpi) is installed and if so, if it is placed in a standard location.

Independently of that, you could also try to set the “MPIparallel” flag in the Makefile to false and recompile.

Hope this helps.



Thank you, problem solved :slight_smile:

Hello KK,

I am having the same error msg while running the tutorials. I have installed the openpmi as you suggested, but still getting the same error. What did you mean by placing it in a standard location? I might be missing something.

I would highly appreciate any help. I am running it on ubuntu.


I think, although OpenMPI have been already installed, but the address might not be set in the environment.
I suggest you to do the following:
1- Set MPI-parallel mode in false mode and check how your program works with single core.
2- In terminal, type "mpirun --version " you should get something like

mpirun (Open MPI) 1.10.2

Report bugs to

otherwise, follow the steps below

note: the guideline is for openmpi version 1.6 however the process is the same as the updated one.

The best,


The code runs fine if I set the “MPIparallel” mode to false. I got the same message after typing “mpirun --version”. What do I do next?

I have also followed your pdf instructions but did not get what to do after the installation. Did you mean to type “echo “export PATH=$PATH: /usr/local/bin” >> $HOME/.bashrc” in the terminal? However, I did type it and getting a syntax error. Any suggestions?


I guess, I found the step you missed.

Open terminal and follow the steps below:
1- type gedit ~/.bashrc
2- at the end of the file add: (noted: assume the software is installed in the location ~/openmpi)
export PATH="$PATH:/home/$USER/openmpi/bin"
export LD_LIBRARY_PATH="$LD_LIBRARY_PATH:/home/$USER/openmpi/lib/"
3- save the file, close the terminal and open a new one.


Thanks Arman. It worked!